ContextMenuItemProps Interface
Deprecated in 4.16.0. Props of deprecated ContextMenuItem component.
Properties for the ContextMenuItem component
Extends
- Omit<React.AllHTMLAttributes<HTMLDivElement>, "disabled" | "hidden">
- CommonProps
Properties
Name | Type | Description | |
---|---|---|---|
badgeKind | string & { T } | "technical-preview" | "new" | "deprecated" | Specifies the kind of badge, if any, to be overlaid on the item. | |
badgeType | BadgeType | undefined | Badge to be overlaid on the item. | Deprecated |
disabled | boolean | ConditionalBooleanValue | Disables any onSelect calls, hover/keyboard highlighting, and grays item. | |
hidden | boolean | ConditionalBooleanValue | Indicates whether the item is visible or hidden. | |
hideIconContainer | boolean | undefined | Hide the icon container. | |
icon | IconSpec | undefined | Icon to display in the left margin. | |
iconRight | IconSpec | undefined | Icon to display in the right margin. | |
isSelected | boolean | undefined | ||
onSelect | (event: any) => any | undefined |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
itemId | string | undefined | CommonProps | Optional unique identifier for item. |
Defined in
Last Updated: 20 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.