ContextSubMenu Class

Deprecated  in 4.16.0. Use subMenuItems property [[iTwinUI MenuItem]] component instead.

Submenu wrapper class for use within a ContextMenu component.

Extends

Methods

Name Description
constructor(props: ContextSubMenuProps): ContextSubMenu    
close(propagate?: boolean): void    
componentDidMount(): void Called immediately after a component is mounted.  
componentWillUnmount(): void Called immediately before a component is destroyed.  
render(): React.ReactElement<any, string | React.JSXElementConstructor<any>>    
select(): void    

Properties

Name Type Description
defaultProps Static Partial<ContextSubMenuProps>    
state Readonly Readonly<ContextSubMenuState>    

Defined in

Last Updated: 30 January, 2025