ContextMenu Class
Deprecated in 4.16.0. Use [[iTwinUI DropdownMenu]] component instead.
A context menu populated with ContextMenuItem components. Can be nested using ContextSubMenu component.
Extends
- React.PureComponent<ContextMenuProps, ContextMenuState>
Methods
Name | Description | |
---|---|---|
constructor(props: ContextMenuProps): ContextMenu | ||
blur(): void | ||
componentDidMount(): void | ||
componentDidUpdate(prevProps: ContextMenuProps): void | ||
componentWillUnmount(): void | ||
focus(): void | ||
getRect(): DOMRect | ||
render(): React.ReactElement<any, string | React.JSXElementConstructor<any>> |
Properties
Name | Type | Description | |
---|---|---|---|
defaultProps Static | Partial<ContextMenuProps> | ||
state Readonly | Readonly<ContextMenuState> |
Defined in
Last Updated: 20 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.