ContextMenuProps Interface
Deprecated in 4.16.0. Props of deprecated ContextMenu component.
Properties for the ContextMenu component
Extends
Properties
Name | Type | Description | |
---|---|---|---|
autoflip | boolean | undefined | Whether menu flips directions based on screen edge. | |
children | React.ReactNode | undefined | Content | |
direction | ContextMenuDirection | undefined | Which direction the menu opens. | |
edgeLimit | boolean | undefined | Whether menu hugs screen edge when autoflip is off. | |
floating | boolean | undefined | whether menu floats on the viewport, or the page. | |
hotkeySelect | boolean | undefined | Whether Hotkey press selects item, or just highlights item. | |
onEsc | (data: any) => any | undefined | when Escape button is pressed | |
onOutsideClick | (event: MouseEvent) => any | undefined | When click is registered outside of ContextMenu. | |
onSelect | (event: any) => any | undefined | When list item or submenu is selected | |
opened | boolean | Whether ContextMenu is currently opened. | |
selectedIndex | number | undefined | starting menu item selected index Default: -1 |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
className | string | undefined | CommonProps | Custom CSS class name |
itemId | string | undefined | CommonProps | Optional unique identifier for item. |
style | React.CSSProperties | undefined | CommonProps | Custom CSS style properties |
Defined in
Last Updated: 20 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.