AuxCoordSystemState Class

The state of an AuxCoordSystem element in the frontend

Extends

Extended by

Implements

Methods

Name Description
constructor(props: AuxCoordSystemProps, iModel: IModelConnection): AuxCoordSystemState    
display(context: DecorateContext, options: ACSDisplayOptions): void    
drawGrid(context: DecorateContext): void    
getOrigin(result?: Point3d): Point3d Abstract    
getRotation(result?: Matrix3d): Matrix3d Abstract get a copy of the rotation matrix for this ACS.  
isValidForView(view: ViewState): boolean    
setOrigin(val: Readonly<WritableXYAndZ> | Readonly<WritableXAndY>): void Abstract    
setRotation(val: Matrix3d): void Abstract    
toJSON(): AuxCoordSystemProps Obtain this element's JSON representation.  
createNew(acsName: string, iModel: IModelConnection): AuxCoordSystemState Static Create a new AuxCoordSystemState.  
fromProps(props: AuxCoordSystemProps, iModel: IModelConnection): AuxCoordSystemState Static    
isOriginInView(drawOrigin: Point3d, viewport: Viewport, adjustOrigin: boolean): boolean Static Given an origin point, returns whether the point falls within the view or not.  

Inherited methods

Name Inherited from Description
clone(iModel?: IModelConnection): this Inherited ElementState Make an independent copy of this EntityState
equals(other: this): boolean Inherited ElementState Return true if this EntityState is equal to another one.

Properties

Name Type Description
className Accessor Static ReadOnly string The name of the BIS class associated with this class.  
description string | undefined    
is3d Accessor ReadOnly boolean    
type number    

Inherited properties

Name Type Inherited from Description
classFullName Accessor Static Inherited ReadOnly string ElementState Get full BIS class name of this Entity in the form "SchemaName:ClassName".
classFullName Readonly Inherited string ElementState The full class name in the form "schema:class".
className Accessor Inherited ReadOnly string ElementState The name of the BIS class associated with this class.
code Readonly Inherited Code ElementState The Code for this element
federationGuid Readonly Inherited string | undefined ElementState A FederationGuid assigned to this element by some other federated database
id Readonly Inherited string ElementState The Id of this Entity.
iModel Readonly Inherited IModelConnection ElementState The iModel from which this Entity was loaded
jsonProperties Readonly Inherited { T } ElementState Optional json properties of this Entity.
model Readonly Inherited string ElementState The ModelId of the Model containing this element
parent Readonly Inherited RelatedElement | undefined ElementState The parent Element of this, or undefined if no parent.
schemaName Accessor Static Inherited ReadOnly string ElementState The name of the BIS schema for this class.
userLabel Readonly Inherited string | undefined ElementState A user-assigned label for this element.

Defined in

Last Updated: 21 November, 2024