AuxCoordSystem3dState Class

The state of an AuxCoordSystem3d element in the frontend

Extends

Extended by

Implements

Methods

Name Description
constructor(props: AuxCoordSystem3dProps, iModel: IModelConnection): AuxCoordSystem3dState    
getOrigin(result?: Point3d): Point3d    
getRotation(result?: Matrix3d): Matrix3d get a copy of the rotation matrix for this ACS.  
setOrigin(val: Readonly<WritableXYAndZ> | Readonly<WritableXAndY>): void    
setRotation(rMatrix: Matrix3d): void    
toJSON(): AuxCoordSystem3dProps Obtain this element's JSON representation.  

Inherited methods

Name Inherited from Description
clone(iModel?: IModelConnection): this Inherited AuxCoordSystemState Make an independent copy of this EntityState
display(context: DecorateContext, options: ACSDisplayOptions): void Inherited AuxCoordSystemState  
drawGrid(context: DecorateContext): void Inherited AuxCoordSystemState  
equals(other: this): boolean Inherited AuxCoordSystemState Return true if this EntityState is equal to another one.
isValidForView(view: ViewState): boolean Inherited AuxCoordSystemState  
createNew(acsName: string, iModel: IModelConnection): AuxCoordSystemState Static Inherited AuxCoordSystemState Create a new AuxCoordSystemState.
fromProps(props: AuxCoordSystemProps, iModel: IModelConnection): AuxCoordSystemState Static Inherited AuxCoordSystemState  
isOriginInView(drawOrigin: Point3d, viewport: Viewport, adjustOrigin: boolean): boolean Static Inherited AuxCoordSystemState Given an origin point, returns whether the point falls within the view or not.

Properties

Name Type Description
className Accessor Static ReadOnly string The name of the BIS class associated with this class.  
origin Readonly Point3d Origin of the AuxCoordSystem3d  
pitch number Pitch angle  
roll number Roll angle  
yaw number Yaw angle  

Inherited properties

Name Type Inherited from Description
classFullName Accessor Static Inherited ReadOnly string AuxCoordSystemState Get full BIS class name of this Entity in the form "SchemaName:ClassName".
classFullName Readonly Inherited string AuxCoordSystemState The full class name in the form "schema:class".
className Accessor Inherited ReadOnly string AuxCoordSystemState The name of the BIS class associated with this class.
code Readonly Inherited Code AuxCoordSystemState The Code for this element
description Inherited string | undefined AuxCoordSystemState  
federationGuid Readonly Inherited string | undefined AuxCoordSystemState A FederationGuid assigned to this element by some other federated database
id Readonly Inherited string AuxCoordSystemState The Id of this Entity.
iModel Readonly Inherited IModelConnection AuxCoordSystemState The iModel from which this Entity was loaded
is3d Accessor Inherited ReadOnly boolean AuxCoordSystemState  
jsonProperties Readonly Inherited { T } AuxCoordSystemState Optional json properties of this Entity.
model Readonly Inherited string AuxCoordSystemState The ModelId of the Model containing this element
parent Readonly Inherited RelatedElement | undefined AuxCoordSystemState The parent Element of this, or undefined if no parent.
schemaName Accessor Static Inherited ReadOnly string AuxCoordSystemState The name of the BIS schema for this class.
type Inherited number AuxCoordSystemState  
userLabel Readonly Inherited string | undefined AuxCoordSystemState A user-assigned label for this element.

Defined in

Last Updated: 21 November, 2024