ElementState Class
The "state" of an Element as represented in a web browser.
Extends
Extended by
Implements
Methods
Name | Description | |
---|---|---|
constructor(props: ElementProps, iModel: IModelConnection): ElementState | ||
toJSON(): ElementProps | Obtain this element's JSON representation. |
Inherited methods
Name | Inherited from | Description |
---|---|---|
clone(iModel?: IModelConnection): this Inherited | EntityState | Make an independent copy of this EntityState |
equals(other: this): boolean Inherited | EntityState | Return true if this EntityState is equal to another one. |
Properties
Name | Type | Description | |
---|---|---|---|
className Accessor Static ReadOnly | string | The name of the BIS class associated with this class. | |
code Readonly | Code | The Code for this element | |
federationGuid Readonly | string | undefined | A FederationGuid assigned to this element by some other federated database | |
model Readonly | string | The ModelId of the Model containing this element | |
parent Readonly | RelatedElement | undefined | The parent Element of this, or undefined if no parent. | |
userLabel Readonly | string | undefined | A user-assigned label for this element. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
classFullName Accessor Static Inherited ReadOnly | string | EntityState | Get full BIS class name of this Entity in the form "SchemaName:ClassName". |
classFullName Readonly Inherited | string | EntityState | The full class name in the form "schema:class". |
className Accessor Inherited ReadOnly | string | EntityState | The name of the BIS class associated with this class. |
id Readonly Inherited | string | EntityState | The Id of this Entity. |
iModel Readonly Inherited | IModelConnection | EntityState | The iModel from which this Entity was loaded |
jsonProperties Readonly Inherited | { T } | EntityState | Optional json properties of this Entity. |
schemaName Accessor Static Inherited ReadOnly | string | EntityState | The name of the BIS schema for this class. |
Defined in
- core/frontend/src/EntityState.ts Line 81
Last Updated: 07 December, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.