MapTile Class

A Tile belonging to a MapTileTree representing a rectangular region of a map of the Earth.

Extends

Methods

Name Description
adjustHeights(minHeight: number, maxHeight: number): void Adjust the minimum and maximum elevations of the terrain within this tile.  
getProjection(heightRange?: Range1d): MapTileProjection Obtain a MapTileProjection to project positions within this tile's area into 3d space.  

Inherited methods

Name Inherited from Description
computeVisibility(args: TileDrawArgs): TileVisibility Inherited RealityTile Determine the visibility of this tile according to the specified args.
countDescendants(): number Inherited RealityTile Primarily for debugging purposes, compute the number of tiles below this one in the TileTree.
dispose(): void Inherited RealityTile Dispose of resources held by this tile and all of its children, marking it and all of its children as "abandoned".
disposeChildren(): void Protected Inherited RealityTile Dispose of this tile's child tiles and mark them as "not loaded".
drawGraphics(args: TileDrawArgs): void Inherited RealityTile Output this tile's graphics.
isFrustumCulled(box: Frustum, args: TileDrawArgs, testClipIntersection: boolean, sphere?: BoundingSphere): boolean Protected Inherited RealityTile  
loadChildren(): TileTreeLoadStatus Protected Inherited RealityTile If this tile's child tiles have not yet been requested, enqueue an asynchronous request to load them.
meetsScreenSpaceError(args: TileDrawArgs): boolean Protected Inherited RealityTile Returns true if this tile is of at least high enough resolution to be displayed, per the supplied TileDrawArgs; or false if
setGraphic(graphic: RenderGraphic): void Protected Inherited RealityTile  
setIsReady(): void Inherited RealityTile  
setLeaf(): void Inherited RealityTile  

Properties

Name Type Description
mapTree Readonly MapTileTree The MapTileTree to which this tile belongs.  
quadId Readonly QuadId Uniquely identifies this tile within its mapTree.  
rectangle Readonly MapCartoRectangle The area of the surface of the Earth that this tile represents.  

Inherited properties

Name Type Inherited from Description
_childrenLoadStatus Protected Inherited TileTreeLoadStatus RealityTile The current loading state of this tile's children.
_contentId Protected Inherited string RealityTile Uniquely identifies this tile's content in the context of its tree.
_contentRange Protected Inherited Range3d | undefined RealityTile A volume no larger than this tile's range, and optionally more tightly encompassing its contents, used for more accurate culling.
_graphic Protected Inherited RenderGraphic | undefined RealityTile This tile's renderable content.
_hadGraphics Protected Inherited boolean RealityTile True if this tile ever had graphics loaded.
_maximumSize Protected Inherited number RealityTile The maximum size in pixels this tile can be drawn.
boundingSphere Readonly Inherited BoundingSphere RealityTile The bounding sphere for this tile.
center Accessor Inherited ReadOnly Point3d RealityTile The point at the center of this tile's volume.
children Accessor Inherited ReadOnly undefined | Tile[] RealityTile This tile's child tiles, if they exist and are loaded. The children are fully contained within this tile's volume and provide higher-resolution graphics than this tile.
contentId Accessor Inherited ReadOnly string RealityTile Uniquely identifies this tile's content.
contentRange Accessor Inherited ReadOnly Range3d RealityTile A volume no larger than this tile's range, and optionally more tightly encompassing its contents, used for more accurate culling.
depth Readonly Inherited number RealityTile The depth of this tile within its TileTree.
geometry Accessor Inherited ReadOnly undefined | RealityTileGeometry RealityTile A representation of the tile's geometry.
This property is only available when using TileGeometryCollector.
hasContentRange Accessor Inherited ReadOnly boolean RealityTile True if this tile has a known volume tightly encompassing its graphics.
iModel Accessor Inherited ReadOnly IModelConnection RealityTile The IModelConnection to which this tile belongs.
isLeaf Accessor Inherited ReadOnly boolean RealityTile True if this tile has no child tiles.
isLoading Accessor Inherited ReadOnly boolean RealityTile True if this tile's content is currently being loaded.
isNotFound Accessor Inherited ReadOnly boolean RealityTile True if an attempt to load this tile's content failed.
isQueued Accessor Inherited ReadOnly boolean RealityTile True if a request for this tile's content has been enqueued.
loadStatus Accessor Inherited ReadOnly TileLoadStatus RealityTile Tile contents are loaded asynchronously on demand. This member tracks the current loading status of this tile's contents.
maximumSize Accessor Inherited ReadOnly number RealityTile The maximum size in pixels this tile can be drawn. If the size of the tile on screen exceeds this maximum, a higher-resolution tile should be drawn in its place.
parent Readonly Inherited undefined | Tile RealityTile The parent of this tile, or undefined if it is the TileTree's root tile.
radius Accessor Inherited ReadOnly number RealityTile The radius of a sphere fully encompassing this tile's volume - used for culling.
range Readonly Inherited Range3d RealityTile The volume of space occupied by this tile.
tree Readonly Inherited TileTree RealityTile The TileTree to which this tile belongs.
usageMarker Readonly Inherited TileUsageMarker RealityTile Tracks the usage of this tile.

Defined in

Last Updated: 21 November, 2024