MapTileProjection Class
Projects points within the rectangular region of a MapTile into 3d space.
@see getProjection to obtain the projection for a MapTile.
Methods
Name | Description | |
---|---|---|
constructor(): MapTileProjection | ||
getPoint(u: number, v: number, height: number, result?: Point3d): Point3d Abstract | Given parametric coordinates in [0, 1] within the tile's rectangular region, and an elevation above the Earth, |
Properties
Name | Type | Description | |
---|---|---|---|
localRange Accessor Abstract ReadOnly | Range3d | The extents of the volume of space associated with the projected MapTile. |
Defined in
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.