UniformArrayParams Interface
Parameters used to define an array of uniform variables for a ScreenSpaceEffectBuilder's shader program.
@see addUniformArray to add a uniform array to an effect shader.
Extends
Properties
Name | Type | Description | |
---|---|---|---|
length | number | The number of elements in the array. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
bind Inherited | (uniform: Uniform, context: UniformContext) => void | UniformParams | A function that computes the value of the variable and binds it to the shader program each time the effect is rendered. |
name Inherited | string | UniformParams | The name of the variable. |
type Inherited | UniformType | UniformParams | The data type of the uniform variable. |
Defined in
Last Updated: 23 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.