UniformParams Interface
Parameters used to define a uniform variable for a ScreenSpaceEffectBuilder's shader program.
@see addUniform to add a uniform variable to an effect shader.
Properties
Name | Type | Description | |
---|---|---|---|
bind | (uniform: Uniform, context: UniformContext) => void | A function that computes the value of the variable and binds it to the shader program each time the effect is rendered. | |
name | string | The name of the variable. | |
type | UniformType | The data type of the uniform variable. |
Defined in
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.