LengthDescription Class
Length Property Description
Extends
Methods
Name | Description | |
---|---|---|
constructor(name?: string, displayLabel?: string, iconSpec?: string): LengthDescription |
Inherited methods
Name | Inherited from | Description |
---|---|---|
formatValue(numberValue: number): string Protected Inherited | FormattedQuantityDescription | |
parseString(userInput: string): ParseResults Protected Inherited | FormattedQuantityDescription |
Properties
Name | Type | Description | |
---|---|---|---|
formatterQuantityType Accessor ReadOnly | QuantityType | ||
parseError Accessor ReadOnly | string | ||
quantityType Accessor ReadOnly | string |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
displayLabel Inherited | string | FormattedQuantityDescription | Display label for the property description |
editor Inherited | PropertyEditorInfo | FormattedQuantityDescription | Information for a property editor |
format Inherited | (numberValue: number) => string | FormattedQuantityDescription | |
formatterSpec Accessor Inherited ReadOnly | undefined | FormatterSpec | FormattedQuantityDescription | |
name Inherited | string | FormattedQuantityDescription | Name of the property description |
parse Inherited | (userInput: string) => ParseResults | FormattedQuantityDescription | |
parserSpec Accessor Inherited ReadOnly | undefined | ParserSpec | FormattedQuantityDescription | |
typename Inherited | string | FormattedQuantityDescription | Type name used to determine applicable Type Converter and Property Editor |
Defined in
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.