QuantityType Enumeration
Defines standard format types for tools that need to display measurements to user.
Members
Name |
Value |
Description |
Angle |
|
Angular value which is stored in radians. Typically formatted to display degrees or Degrees-Minute-Seconds based on active unit system. |
Area |
|
Area value store in meters squared. Typically formatted to display in meters squared or feet squared based on active unit system. |
Coordinate |
|
Coordinate/Location value which is stored in meters. Typically formatted to display in meters or feet based on active unit system. |
LatLong |
|
LatLong is an angular value which is stored in radians. Typically formatted to display degrees or Degrees-Minute-Seconds based on active unit system. |
Length |
|
Length which is stored in meters. Typically formatted to display in meters or feet-inches based on active unit system. |
LengthEngineering |
|
LengthEngineering is a distance value stored in meters. Typically formatted to display either meters or feet based on active unit system. |
LengthSurvey |
|
LengthSurvey is a distance value stored in meters. Typically formatted to display in meters or US Survey Feet based on active unit system.. |
Stationing |
|
Stationing is a distance value stored in meters. Typically formatted to display xxx+xx or xx+xxx based on active unit system. |
Volume |
|
Volume value which is stored in meters cubed. Typically formatted to display in meters cubed or feet cubed based on active unit system. |
Defined in
Last Updated: 23 November, 2024