ServerTimeoutError Class

Extends

Methods

Name Description
constructor(message: string): ServerTimeoutError    

Inherited methods

Name Inherited from Description
_initName(): string Protected Inherited ServerError This function returns the name of each error status.
ServerError get the meta data associated with this BentleyError, if any.
getErrorKey(errorNumber: number): string Static Inherited ServerError This function returns the name of each error status.
getErrorMessage(error: unknown): string Static Inherited ServerError Use run-time type checking to safely get a useful string summary of an unknown error value, or "" if none exists.
ServerError Use run-time type checking to safely get the metadata with an unknown error value, if possible.
getErrorProps(error: unknown): ErrorProps Static Inherited ServerError Returns a new ErrorProps object representing an unknown error value.
getErrorStack(error: unknown): undefined | string Static Inherited ServerError Use run-time type checking to safely get the call stack of an unknown error value, if possible.
ServerError get the metadata object associated with an ExceptionMetaData, if any.
isError<T extends LegacyITwinErrorWithNumber>(error: unknown, errorNumber?: number): error is T Static Inherited ServerError Determine if an error object implements the LegacyITwinErrorWithNumber interface.

Inherited properties

Name Type Inherited from Description
errorNumber Inherited number ServerError  
boolean ServerError Returns true if this BentleyError includes (optional) metadata.
iTwinErrorId Accessor Inherited ReadOnly { key: string, scope: string } ServerError supply the value for iTwinErrorId
iTwinErrorScope Static Readonly Inherited "bentley-error" ServerError  
undefined | object ServerError value for logging metadata

Defined in

Last Updated: 03 April, 2025