ServerError Class

Extends

Extended by

Methods

Name Description
constructor(errorNumber: number, message: string): ServerError    

Inherited methods

Name Inherited from Description
_initName(): string Protected Inherited IModelError This function returns the name of each error status.
IModelError get the meta data associated with this BentleyError, if any.
getErrorMessage(error: unknown): string Static Inherited IModelError Use run-time type checking to safely get a useful string summary of an unknown error value, or "" if none exists.
IModelError Use run-time type checking to safely get the metadata with an unknown error value, if possible.
getErrorProps(error: unknown): ErrorProps Static Inherited IModelError Returns a new ErrorProps object representing an unknown error value.
getErrorStack(error: unknown): undefined | string Static Inherited IModelError Use run-time type checking to safely get the call stack of an unknown error value, if possible.
IModelError get the metadata object associated with an ExceptionMetaData, if any.

Inherited properties

Name Type Inherited from Description
errorNumber Inherited number IModelError  
boolean IModelError Returns true if this BentleyError includes (optional) metadata.

Defined in

Last Updated: 21 November, 2024