WorkspaceEditor Namespace
Function
Name | Description |
---|---|
WorkspaceEditor.construct | Create a new WorkspaceEditor for creating new versions of WorkspaceDbs. |
WorkspaceEditor.createEmptyDb | Create a new, empty, EditableWorkspaceDb file on the local filesystem for importing Workspace resources. |
Defined in
WorkspaceEditor Interface
An object that permits administrators to modify the contents of a Workspace. Use construct to obtain a WorkspaceEditor, and close when finished using it. Only one WorkspaceEditor may be in use at any given time. Use getContainer to edit an existing WorkspaceContainer, or createNewCloudContainer to create a new WorkspaceContainer.
Methods
Name | Description | |
---|---|---|
close(): void | Closes this editor. | |
createNewCloudContainer(args: CreateNewWorkspaceContainerArgs): Promise<EditableWorkspaceContainer> | Creates a new cloud container for holding WorkspaceDbs, from the BlobContainer service. | |
getContainer(args: GetWorkspaceContainerArgs): EditableWorkspaceContainer | Retrieves a container for the editor with the specified properties and access token. | |
getContainerAsync(props: WorkspaceContainerProps): Promise<EditableWorkspaceContainer> | Asynchronously retrieves a container for the editor with the specified properties. |
Properties
Name | Type | Description | |
---|---|---|---|
workspace Readonly | Workspace | The workspace dedicated to this editor. |
Defined in
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.