GetWorkspaceContainerArgs Interface

Arguments supplied to getContainer and getContainer.

Extends

Properties

Name Type Description
accessToken string Token required to access the container.  

Inherited properties

Name Type Inherited from Description
alias Readonly Inherited string | undefined WorkspaceContainerProps an alias for the container.
baseUri Readonly Inherited string WorkspaceContainerProps The base URI for the container.
containerId Readonly Inherited string WorkspaceContainerProps The name of the container.
description Readonly Inherited string | undefined WorkspaceContainerProps A user-friendly description of the container's contents.
isPublic Readonly Inherited boolean | undefined WorkspaceContainerProps true if the container is public (doesn't require authorization)
loadingHelp Readonly Inherited string | undefined WorkspaceContainerProps A message to display to the user if problems occur while loading the container.
lockExpireSeconds Readonly Inherited number | undefined WorkspaceContainerProps Duration for holding write lock, in seconds.
logId Readonly Inherited string | undefined WorkspaceContainerProps string attached to log messages from CloudSQLite.
secure Readonly Inherited boolean | undefined WorkspaceContainerProps if true, container is attached in "secure" mode (blocks are encrypted).
storageType Readonly Inherited "azure" | "google" WorkspaceContainerProps The type of storage provider.
syncOnConnect Readonly Inherited boolean | undefined WorkspaceContainerProps Whether to synchronize the container via CloudSqlite.CloudContainer.checkForChanges whenever it is connected to a CloudCache.
tokenRefreshSeconds Readonly Inherited number | undefined WorkspaceContainerProps number of seconds between auto-refresh of access token.
writeable Readonly Inherited boolean | undefined WorkspaceContainerProps if true, container is allowed to request the write lock.

Defined in

Last Updated: 21 November, 2024