GraphicalElement3dRepresentsElement Class
Relates a GraphicalElement3d to the Element that it represents
Extends
Methods
Inherited methods
Name |
Inherited from |
Description |
collectReferenceIds(referenceIds: EntityReferenceSet): void Protected Inherited |
ElementRefersToElements |
Collect the Ids of this entity's references at this level of the class hierarchy. |
delete(): void Inherited |
ElementRefersToElements |
Delete this Relationship from the iModel. |
forEach(func: PropertyHandler, includeCustom: booleantrue): void Inherited |
ElementRefersToElements |
Call a function for each property of this Entity. |
forEachProperty(func: PropertyCallback, includeCustom: booleantrue): void Inherited |
ElementRefersToElements |
Call a function for each property of this Entity. |
getMetaData(): Promise<EntityClass> Inherited |
ElementRefersToElements |
query metadata for this entity class from the iModel's schema |
getReferenceIds(): EntityReferenceSet Inherited |
ElementRefersToElements |
Get the set of this entity's entity references, EntityReferenceSet. |
insert(): string Inherited |
ElementRefersToElements |
Insert this Relationship into the iModel. |
toJSON(): RelationshipProps Inherited |
ElementRefersToElements |
Obtain the JSON representation of this Entity. |
update(): void Inherited |
ElementRefersToElements |
Update this Relationship in the iModel. |
create<T extends ElementRefersToElements>(iModel: IModelDb, sourceId: string, targetId: string): T Static Inherited |
ElementRefersToElements |
Create an instance of the Relationship. |
getInstance<T extends Relationship>(iModel: IModelDb, criteria: string | SourceAndTarget): T Static Inherited |
ElementRefersToElements |
|
insert<T extends ElementRefersToElements>(iModel: IModelDb, sourceId: string, targetId: string): string Static Inherited |
ElementRefersToElements |
Insert a new instance of the Relationship. |
is(otherClass: ): boolean Static Inherited |
ElementRefersToElements |
return whether this Entity class is a subclass of another Entity class |
onDeletedDependency(_props: RelationshipProps, _iModel: IModelDb): void Static Inherited |
ElementRefersToElements |
Callback invoked by saveChanges on an ElementDrivesElement relationship when the relationship instance has been deleted. |
onRootChanged(_props: RelationshipProps, _iModel: IModelDb): void Static Inherited |
ElementRefersToElements |
Callback invoked by saveChanges on an ElementDrivesElement relationship when its input has changed or is the output of some upstream relationship whose input has changed. |
Properties
Name |
Type |
Description |
|
className Accessor Static ReadOnly |
string |
The name of the BIS class associated with this class. |
|
Inherited properties
Defined in
Last Updated: 03 April, 2025