SpatialLocationModel Class

A container for persisting spatial location elements.

@see SpatialLocationPartition

Extends

Methods

Name Description
constructor(props: GeometricModel3dProps, iModel: IModelDb): SpatialLocationModel Protected    
insert(iModelDb: IModelDb, parentSubjectId: string, name: string, isPlanProjection?: boolean): string Static Insert a SpatialLocationPartition and a SpatialLocationModel that sub-models it.  

Inherited methods

Name Inherited from Description
collectReferenceIds(referenceIds: EntityReferenceSet): void Protected Inherited SpatialModel Collect the Ids of this entity's references at this level of the class hierarchy.
delete(): void Inherited SpatialModel Delete this Model from the iModel.
forEachProperty(func: PropertyCallback, includeCustom: booleantrue): void Inherited SpatialModel Call a function for each property of this Entity.
getJsonProperty(name: string): any Inherited SpatialModel  
getReferenceIds(): EntityReferenceSet Inherited SpatialModel Get the set of this entity's entity references, EntityReferenceSet.
getUserProperties(namespace: string): any Inherited SpatialModel Get a set of JSON user properties by namespace
insert(): string Inherited SpatialModel Insert this Model in the iModel
queryExtents(): Range3d Inherited SpatialModel Query for the union of the extents of the elements contained by this model.
queryRange(): Promise<Range3d> Inherited SpatialModel Query for the union of the extents of all elements contained within this model.
removeUserProperties(nameSpace: string): void Inherited SpatialModel Remove a set of JSON user properties, specified by namespace, from this Element
setJsonProperty(name: string, value: any): void Inherited SpatialModel  
setUserProperties(nameSpace: string, value: any): void Inherited SpatialModel Change a set of user JSON properties of this Element by namespace.
toJSON(): GeometricModel3dProps Inherited SpatialModel Obtain the JSON representation of this Entity.
update(): void Inherited SpatialModel Update this Model in the iModel.
is(otherClass: ): boolean Static Inherited SpatialModel return whether this Entity class is a subclass of another Entity class
onDelete(arg: OnModelIdArg): void Protected Static Inherited SpatialModel Called before a Model is deleted.
onDeleted(_arg: OnModelIdArg): void Protected Static Inherited SpatialModel Called after a Model was deleted.
onDeletedElement(_arg: OnElementInModelIdArg): void Protected Static Inherited SpatialModel Called after an Element in an instance of a Model of this class has been deleted.
onDeleteElement(_arg: OnElementInModelIdArg): void Protected Static Inherited SpatialModel Called when an Element in an instance of a Model of this class is about to be deleted.
onInsert(arg: OnModelPropsArg): void Protected Static Inherited SpatialModel Called before a new Model is inserted.
onInserted(_arg: OnModelIdArg): void Protected Static Inherited SpatialModel Called after a new Model is inserted.
onInsertedElement(_arg: OnElementInModelIdArg): void Protected Static Inherited SpatialModel Called after an Element has been inserted into an instance of a Model of this class.
onInsertElement(_arg: OnElementInModelPropsArg): void Protected Static Inherited SpatialModel Called before a prospective Element is to be inserted into an instance of a Model of this class.
onUpdate(arg: OnModelPropsArg): void Protected Static Inherited SpatialModel Called before a Model is updated.
onUpdated(_arg: OnModelIdArg): void Protected Static Inherited SpatialModel Called after a Model is updated.
onUpdatedElement(_arg: OnElementInModelIdArg): void Protected Static Inherited SpatialModel Called after an Element in an instance of a Model of this class has been updated.
onUpdateElement(_arg: OnElementInModelPropsArg): void Protected Static Inherited SpatialModel Called when an Element in an instance of a Model of this class is about to be updated.

Properties

Name Type Description
className Accessor Static ReadOnly string The name of the BIS class associated with this class.  

Inherited properties

Name Type Inherited from Description
classFullName Accessor Inherited ReadOnly string SpatialModel Get the full BIS class name of this Entity in the form "schema:class".
classFullName Accessor Static Inherited ReadOnly string SpatialModel Get the full BIS class name of this Entity in the form "schema:class"
className Accessor Inherited ReadOnly string SpatialModel The name of the BIS class associated with this class.
geometryGuid Inherited string | undefined SpatialModel  
id Inherited string SpatialModel The Id of this Entity.
iModel Inherited IModelDb SpatialModel The IModelDb that contains this Entity
isInstanceOfEntity Readonly Inherited "true" SpatialModel An immutable property used to discriminate between Entity and EntityProps, used to inform the TypeScript compiler that these two types
isNotSpatiallyLocated Readonly Inherited boolean SpatialModel If true, then the elements in this GeometricModel3d are not in real-world coordinates and will not be in the spatial index.
isPlanProjection Readonly Inherited boolean SpatialModel If true, then the elements in this GeometricModel3d are expected to be in an XY plane.
isPrivate Inherited boolean SpatialModel  
isSpatiallyLocated Accessor Inherited ReadOnly boolean SpatialModel If true, then the elements in this GeometricModel3d are in real-world coordinates and will be in the spatial index.
isTemplate Inherited boolean SpatialModel  
jsonProperties Readonly Inherited { T } SpatialModel  
modeledElement Readonly Inherited RelatedElement SpatialModel  
name Readonly Inherited string SpatialModel  
parentModel Readonly Inherited string SpatialModel  
schema Static Inherited SpatialModel The Schema that defines this class.
schemaName Accessor Inherited ReadOnly string SpatialModel The name of the BIS Schema that defines this class

Defined in

Last Updated: 21 November, 2024