RoleModel Class

A container for persisting role elements.

Extends

Extended by

Methods

Name Description
constructor(props: ModelProps, iModel: IModelDb): RoleModel Protected    

Inherited methods

Name Inherited from Description
collectReferenceIds(referenceIds: EntityReferenceSet): void Protected Inherited Model Collect the Ids of this entity's references at this level of the class hierarchy.
delete(): void Inherited Model Delete this Model from the iModel.
forEachProperty(func: PropertyCallback, includeCustom: booleantrue): void Inherited Model Call a function for each property of this Entity.
getJsonProperty(name: string): any Inherited Model  
getReferenceIds(): EntityReferenceSet Inherited Model Get the set of this entity's entity references, EntityReferenceSet.
getUserProperties(namespace: string): any Inherited Model Get a set of JSON user properties by namespace
insert(): string Inherited Model Insert this Model in the iModel
removeUserProperties(nameSpace: string): void Inherited Model Remove a set of JSON user properties, specified by namespace, from this Element
setJsonProperty(name: string, value: any): void Inherited Model  
setUserProperties(nameSpace: string, value: any): void Inherited Model Change a set of user JSON properties of this Element by namespace.
toJSON(): ModelProps Inherited Model Obtain the JSON representation of this Entity.
update(): void Inherited Model Update this Model in the iModel.
is(otherClass: ): boolean Static Inherited Model return whether this Entity class is a subclass of another Entity class
onDelete(arg: OnModelIdArg): void Protected Static Inherited Model Called before a Model is deleted.
onDeleted(_arg: OnModelIdArg): void Protected Static Inherited Model Called after a Model was deleted.
onDeletedElement(_arg: OnElementInModelIdArg): void Protected Static Inherited Model Called after an Element in an instance of a Model of this class has been deleted.
onDeleteElement(_arg: OnElementInModelIdArg): void Protected Static Inherited Model Called when an Element in an instance of a Model of this class is about to be deleted.
onInsert(arg: OnModelPropsArg): void Protected Static Inherited Model Called before a new Model is inserted.
onInserted(_arg: OnModelIdArg): void Protected Static Inherited Model Called after a new Model is inserted.
onInsertedElement(_arg: OnElementInModelIdArg): void Protected Static Inherited Model Called after an Element has been inserted into an instance of a Model of this class.
onInsertElement(_arg: OnElementInModelPropsArg): void Protected Static Inherited Model Called before a prospective Element is to be inserted into an instance of a Model of this class.
onUpdate(arg: OnModelPropsArg): void Protected Static Inherited Model Called before a Model is updated.
onUpdated(_arg: OnModelIdArg): void Protected Static Inherited Model Called after a Model is updated.
onUpdatedElement(_arg: OnElementInModelIdArg): void Protected Static Inherited Model Called after an Element in an instance of a Model of this class has been updated.
onUpdateElement(_arg: OnElementInModelPropsArg): void Protected Static Inherited Model Called when an Element in an instance of a Model of this class is about to be updated.

Properties

Name Type Description
className Accessor Static ReadOnly string The name of the BIS class associated with this class.  

Inherited properties

Name Type Inherited from Description
classFullName Accessor Inherited ReadOnly string Model Get the full BIS class name of this Entity in the form "schema:class".
classFullName Accessor Static Inherited ReadOnly string Model Get the full BIS class name of this Entity in the form "schema:class"
className Accessor Inherited ReadOnly string Model The name of the BIS class associated with this class.
id Inherited string Model The Id of this Entity.
iModel Inherited IModelDb Model The IModelDb that contains this Entity
isInstanceOfEntity Readonly Inherited "true" Model An immutable property used to discriminate between Entity and EntityProps, used to inform the TypeScript compiler that these two types
isPrivate Inherited boolean Model  
isTemplate Inherited boolean Model  
jsonProperties Readonly Inherited { T } Model  
modeledElement Readonly Inherited RelatedElement Model  
name Readonly Inherited string Model  
parentModel Readonly Inherited string Model  
schema Static Inherited Model The Schema that defines this class.
schemaName Accessor Inherited ReadOnly string Model The name of the BIS Schema that defines this class

Defined in

Last Updated: 21 November, 2024