GenericGraphicalModel3d Class

A generic container for persisting BisCore:GraphicalElement3d instances.

Extends

Methods

Name Description
constructor(props: GeometricModel3dProps, iModel: IModelDb): GenericGraphicalModel3d    
insert(iModelDb: IModelDb, parentSubjectId: string, name: string, isPlanProjection?: boolean): string Static Insert a BisCore:GraphicalPartition3d and a Generic:GraphicalModel3d that sub-models it.  

Inherited methods

Name Inherited from Description
collectReferenceIds(referenceIds: EntityReferenceSet): void Protected Inherited GraphicalModel3d Collect the Ids of this entity's references at this level of the class hierarchy.
delete(): void Inherited GraphicalModel3d Delete this Model from the iModel.
forEachProperty(func: PropertyCallback, includeCustom: booleantrue): void Inherited GraphicalModel3d Call a function for each property of this Entity.
getJsonProperty(name: string): any Inherited GraphicalModel3d  
getReferenceIds(): EntityReferenceSet Inherited GraphicalModel3d Get the set of this entity's entity references, EntityReferenceSet.
getUserProperties(namespace: string): any Inherited GraphicalModel3d Get a set of JSON user properties by namespace
insert(): string Inherited GraphicalModel3d Insert this Model in the iModel
queryExtents(): Range3d Inherited GraphicalModel3d Query for the union of the extents of the elements contained by this model.
queryRange(): Promise<Range3d> Inherited GraphicalModel3d Query for the union of the extents of all elements contained within this model.
removeUserProperties(nameSpace: string): void Inherited GraphicalModel3d Remove a set of JSON user properties, specified by namespace, from this Element
setJsonProperty(name: string, value: any): void Inherited GraphicalModel3d  
setUserProperties(nameSpace: string, value: any): void Inherited GraphicalModel3d Change a set of user JSON properties of this Element by namespace.
toJSON(): GeometricModel3dProps Inherited GraphicalModel3d Obtain the JSON representation of this Entity.
update(): void Inherited GraphicalModel3d Update this Model in the iModel.
is(otherClass: ): boolean Static Inherited GraphicalModel3d return whether this Entity class is a subclass of another Entity class
onDelete(arg: OnModelIdArg): void Protected Static Inherited GraphicalModel3d Called before a Model is deleted.
onDeleted(_arg: OnModelIdArg): void Protected Static Inherited GraphicalModel3d Called after a Model was deleted.
onDeletedElement(_arg: OnElementInModelIdArg): void Protected Static Inherited GraphicalModel3d Called after an Element in an instance of a Model of this class has been deleted.
onDeleteElement(_arg: OnElementInModelIdArg): void Protected Static Inherited GraphicalModel3d Called when an Element in an instance of a Model of this class is about to be deleted.
onInsert(arg: OnModelPropsArg): void Protected Static Inherited GraphicalModel3d Called before a new Model is inserted.
onInserted(_arg: OnModelIdArg): void Protected Static Inherited GraphicalModel3d Called after a new Model is inserted.
onInsertedElement(_arg: OnElementInModelIdArg): void Protected Static Inherited GraphicalModel3d Called after an Element has been inserted into an instance of a Model of this class.
onInsertElement(_arg: OnElementInModelPropsArg): void Protected Static Inherited GraphicalModel3d Called before a prospective Element is to be inserted into an instance of a Model of this class.
onUpdate(arg: OnModelPropsArg): void Protected Static Inherited GraphicalModel3d Called before a Model is updated.
onUpdated(_arg: OnModelIdArg): void Protected Static Inherited GraphicalModel3d Called after a Model is updated.
onUpdatedElement(_arg: OnElementInModelIdArg): void Protected Static Inherited GraphicalModel3d Called after an Element in an instance of a Model of this class has been updated.
onUpdateElement(_arg: OnElementInModelPropsArg): void Protected Static Inherited GraphicalModel3d Called when an Element in an instance of a Model of this class is about to be updated.

Properties

Name Type Description
className Accessor Static ReadOnly string The name of the BIS class associated with this class.  

Inherited properties

Name Type Inherited from Description
classFullName Accessor Inherited ReadOnly string GraphicalModel3d Get the full BIS class name of this Entity in the form "schema:class".
classFullName Accessor Static Inherited ReadOnly string GraphicalModel3d Get the full BIS class name of this Entity in the form "schema:class"
className Accessor Inherited ReadOnly string GraphicalModel3d The name of the BIS class associated with this class.
geometryGuid Inherited string | undefined GraphicalModel3d  
id Inherited string GraphicalModel3d The Id of this Entity.
iModel Inherited IModelDb GraphicalModel3d The IModelDb that contains this Entity
isInstanceOfEntity Readonly Inherited "true" GraphicalModel3d An immutable property used to discriminate between Entity and EntityProps, used to inform the TypeScript compiler that these two types
isNotSpatiallyLocated Readonly Inherited boolean GraphicalModel3d If true, then the elements in this GeometricModel3d are not in real-world coordinates and will not be in the spatial index.
isPlanProjection Readonly Inherited boolean GraphicalModel3d If true, then the elements in this GeometricModel3d are expected to be in an XY plane.
isPrivate Inherited boolean GraphicalModel3d  
isSpatiallyLocated Accessor Inherited ReadOnly boolean GraphicalModel3d If true, then the elements in this GeometricModel3d are in real-world coordinates and will be in the spatial index.
isTemplate Inherited boolean GraphicalModel3d  
jsonProperties Readonly Inherited { T } GraphicalModel3d  
modeledElement Readonly Inherited RelatedElement GraphicalModel3d  
name Readonly Inherited string GraphicalModel3d  
parentModel Readonly Inherited string GraphicalModel3d  
schema Static Inherited GraphicalModel3d The Schema that defines this class.
schemaName Accessor Inherited ReadOnly string GraphicalModel3d The name of the BIS Schema that defines this class

Defined in

Last Updated: 21 November, 2024