LineStyleDefinition.StrokeProps Interface

A stroke representing either a dash or gap in a stroke pattern

Properties

Name Type Description
capMode LineStyleDefinition.StrokeCap | undefined Appearance of stroke end cap  
endWidth number | undefined Width at end of stroke, same as start width if not present.  
length number Length of stroke in meters  
orgWidth number | undefined Width at start of stroke.  
strokeMode LineStyleDefinition.StrokeMode | undefined Type and behavior of stroke  
widthMode LineStyleDefinition.StrokeWidth | undefined How to apply orgWidth and endWidth to stroke  

Defined in

Last Updated: 21 November, 2024