LineStyleDefinition.StrokeMode Enumeration
Mask of values for StrokeMode
Members
Name | Value | Description |
---|---|---|
Dash | Stroke represents a solid dash | |
FirstInvert | Invert stroke in first stroke pattern | |
Gap | Stroke represents a blank space | |
LastInvert | Invert stroke in last stroke pattern | |
Ray | Treat stroke as rigid and continue past a corner to complete the stroke as opposed to breaking at the corner | |
Scale | Stroke length can be stretched when LineStyleDefinition.StrokePatternOptions.Iteration and LineStyleDefinition.StrokePatternOptions.AutoPhase options are set, applicable to both Gap and Dash strokes |
Defined in
- core/backend/src/LineStyle.ts Line 43
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.