IMutableCategorizedPropertyItem Interface
Data structure which describes methods and properties to be held by Mutable CategorizedPropertyItems
Extends
Implemented by
- MutableCategorizedArrayProperty
- MutableCategorizedPrimitiveProperty
- MutableCategorizedStructProperty
Methods
Name | Description | |
---|---|---|
getChildren(): IMutableCategorizedPropertyItem[] |
Inherited methods
Properties
Name | Type | Description | |
---|---|---|---|
derivedRecord Readonly | PropertyRecord | ||
parentCategorySelectionKey Readonly | string | ||
parentSelectionKey Readonly | string | ||
type Readonly | CategorizedPropertyTypes |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
depth Readonly | number | IMutableFlatPropertyGridItem | |
isExpanded | boolean | IMutableFlatPropertyGridItem | |
isLastInRootCategory | boolean | IMutableFlatPropertyGridItem | |
key Readonly | string | IMutableFlatPropertyGridItem | |
label Readonly | string | IMutableFlatPropertyGridItem | |
lastInNumberOfCategories | number | IMutableFlatPropertyGridItem | |
selectionKey Readonly | string | IMutableFlatPropertyGridItem |
Defined in
Last Updated: 20 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.