IMutableFlatPropertyGridItem Interface
Base mutable data structure defining common methods and properties for both CategorizedProperties and GridCategoryItems
Implemented by
Methods
Name | Description | |
---|---|---|
getChildren(): IMutableFlatGridItem[] | ||
getDescendantsAndSelf(): IMutableFlatGridItem[] | ||
getLastVisibleDescendantOrSelf(): IMutableFlatGridItem | ||
getVisibleDescendantsAndSelf(): IMutableFlatGridItem[] |
Properties
Name | Type | Description | |
---|---|---|---|
depth Readonly | number | ||
isExpanded | boolean | ||
isLastInRootCategory | boolean | ||
key Readonly | string | ||
label Readonly | string | ||
lastInNumberOfCategories | number | ||
parentCategorySelectionKey Readonly | undefined | string | ||
parentSelectionKey Readonly | undefined | string | ||
selectionKey Readonly | string | ||
type Readonly | FlatGridItemType |
Defined in
Last Updated: 20 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.