NodeCliAuthorizationClient Class
Utility to generate OIDC/OAuth tokens for command-line applications This client is intended for developer tooling and does not aspire to provide the full set of functionality needed for a user-facing app.
Implements
Methods
Name | Description | |
---|---|---|
constructor(config: NodeCliAuthorizationConfiguration): NodeCliAuthorizationClient | ||
getAccessToken(): Promise<string> | Returns a promise that resolves to the AccessToken of the currently authorized user. | |
signIn(): Promise<void> | Attempts to authorize the current user, and resolves when the authorization process is complete. | |
signOut(): Promise<void> | Clear cached credential (if any). |
Defined in
- Client.ts Line 89
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.