NodeCliAuthorizationConfiguration Interface
Client configuration to generate OIDC/OAuth tokens for command-line applications
Properties
Name | Type | Description | |
---|---|---|---|
clientId Readonly | string | Client application's identifier as registered with the OIDC/OAuth2 provider. | |
expiryBuffer Readonly | number | undefined | Time in seconds that's used as a buffer to check the token for validity/expiry. | |
issuerUrl Readonly | string | undefined | The OAuth token issuer URL. | |
redirectUri Readonly | string | undefined | Upon signing in, the client application receives a response from the Bentley IMS OIDC/OAuth2 provider at this URI | |
scope Readonly | string | List of space separated scopes to request access to various resources. | |
tokenStorePath Readonly | string | undefined | Directory path that overrides where the refresh token is stored, see TokenStore |
Defined in
- Client.ts Line 42
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.