SetMapBaseTool Class

Sets map layer base tool.

Extends

Methods

Name Description
constructor(): SetMapBaseTool    

Inherited methods

Name Inherited from Description
doAttach(source?: MapLayerSource): void Protected Inherited AttachMapLayerTool  
parseAndRun(...args: string[]): Promise<boolean> Inherited AttachMapLayerTool Executes this tool's run method with args[0] containing name.
run(name: string): Promise<boolean> Inherited AttachMapLayerTool This method runs the tool, adding a map layer from a specified name in MayLayerSources.json.
register(namespace?: string): void Static Inherited AttachMapLayerTool Register this Tool class with the ToolRegistry.

Properties

Name Type Description
toolId Static string    

Inherited properties

Name Type Inherited from Description
_isBackground Protected Inherited boolean AttachMapLayerTool  
_isBase Protected Inherited boolean AttachMapLayerTool  
description Accessor Inherited ReadOnly string AttachMapLayerTool Get the localized description string from this Tool's class
description Accessor Static Inherited ReadOnly string AttachMapLayerTool Get the localized description for this Tool class. This returns the value of "tools." + this.toolId + ".description" from
its registered Namespace (e.g. "en/MyApp.json"). If that key is not in the localization namespace,
flyover is returned.
englishKeyin Accessor Static Inherited ReadOnly string AttachMapLayerTool Get the English keyin string for this Tool class. This returns the value of "tools." + this.toolId + ".keyin" from
its registered Namespace (e.g. "en/MyApp.json").
flyover Accessor Inherited ReadOnly string AttachMapLayerTool Get the localized flyover string from this Tool's class
flyover Accessor Static Inherited ReadOnly string AttachMapLayerTool Get the localized flyover for this Tool class. This returns the value of "tools." + this.toolId + ".flyover" from
its registered Namespace (e.g. "en/MyApp.json"). If that key is not in the localization namespace,
keyin is returned.
hidden Static Inherited boolean AttachMapLayerTool If true, this Tool will not appear in the list from ToolRegistry.getToolList.
iconSpec Accessor Inherited ReadOnly string AttachMapLayerTool Get the iconSpec from this Tool's class.
iconSpec Static Inherited string AttachMapLayerTool The icon for this Tool.
keyin Accessor Inherited ReadOnly string AttachMapLayerTool Get the localized keyin string from this Tool's class
keyin Accessor Static Inherited ReadOnly string AttachMapLayerTool Get the localized keyin string for this Tool class. This returns the value of "tools." + this.toolId + ".keyin" from
its registered Namespace (e.g. "en/MyApp.json").
maxArgs Accessor Static Inherited ReadOnly number AttachMapLayerTool The maximum number of arguments allowed by parseAndRun, or undefined if there is no maximum.
If subclasses override parseAndRun, they should also override this method to indicate the maximum
number of arguments their implementation expects.
minArgs Accessor Static Inherited ReadOnly number AttachMapLayerTool The minimum number of arguments allowed by parseAndRun. If subclasses override parseAndRun, they should also
override this method to indicate the minimum number of arguments their implementation expects. UI controls can use
this information to ensure the tool has enough information to execute.
namespace Static Inherited string AttachMapLayerTool The namespace that provides localized strings for this Tool.
toolId Accessor Inherited ReadOnly string AttachMapLayerTool Get the toolId string for this Tool class. This string is used to identify the Tool in the ToolRegistry and is used to localize
the keyin, description, etc. from the current locale.

Defined in

Last Updated: 21 November, 2024