MapLayerSource Class
A source for map layers. These may be catalogued for convenient use by users or applications.
Methods
Name | Description | |
---|---|---|
collectQueryParams(): { T } | Collect all query parameters | |
toJSON(): Omit<MapLayerSourceProps, "formatId"> & { formatId: string } | ||
toLayerSettings(subLayers?: MapSubLayerProps[]): undefined | ImageMapLayerSettings | ||
validateSource(ignoreCache?: boolean): Promise<MapLayerSourceValidation> | ||
fromJSON(json: MapLayerSourceProps): undefined | MapLayerSource Static |
Properties
Defined in
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.