AttachWmtsMapLayerByUrlTool Class

This tool attaches a WMTS map layer from a given URL.

Extends

  • AttachMapLayerByURLBaseTool

Methods

Name Description
constructor(): AttachWmtsMapLayerByUrlTool    
parseAndRun(...args: string[]): Promise<boolean> This method runs the tool, attaching a WMTS map layer from a given URL.  

Inherited methods

Name Inherited from Description
doAttach(source?: MapLayerSource): void Protected Inherited AttachMapLayerByURLBaseTool  
run(url: string, name?: string, userName?: string, password?: string): Promise<boolean> Inherited AttachMapLayerByURLBaseTool Run this instance of a Tool.
register(namespace?: string): void Static Inherited AttachMapLayerByURLBaseTool Register this Tool class with the ToolRegistry.

Properties

Name Type Description
toolId Static string The unique string that identifies this tool.  

Inherited properties

Name Type Inherited from Description
_formatId Protected Inherited string AttachMapLayerByURLBaseTool  
_isBackground Protected Inherited boolean AttachMapLayerByURLBaseTool  
_isBase Protected Inherited boolean AttachMapLayerByURLBaseTool  
description Accessor Inherited ReadOnly string AttachMapLayerByURLBaseTool Get the localized description string from this Tool's class
description Accessor Static Inherited ReadOnly string AttachMapLayerByURLBaseTool Get the localized description for this Tool class. This returns the value of "tools." + this.toolId + ".description" from
its registered Namespace (e.g. "en/MyApp.json"). If that key is not in the localization namespace,
AttachMapLayerByURLBaseTool.flyover is returned.
englishKeyin Accessor Static Inherited ReadOnly string AttachMapLayerByURLBaseTool Get the English keyin string for this Tool class. This returns the value of "tools." + this.toolId + ".keyin" from
its registered Namespace (e.g. "en/MyApp.json").
flyover Accessor Inherited ReadOnly string AttachMapLayerByURLBaseTool Get the localized flyover string from this Tool's class
flyover Accessor Static Inherited ReadOnly string AttachMapLayerByURLBaseTool Get the localized flyover for this Tool class. This returns the value of "tools." + this.toolId + ".flyover" from
its registered Namespace (e.g. "en/MyApp.json"). If that key is not in the localization namespace,
AttachMapLayerByURLBaseTool.keyin is returned.
hidden Static Inherited boolean AttachMapLayerByURLBaseTool If true, this Tool will not appear in the list from ToolRegistry.getToolList.
iconSpec Accessor Inherited ReadOnly string AttachMapLayerByURLBaseTool Get the iconSpec from this Tool's class.
iconSpec Static Inherited string AttachMapLayerByURLBaseTool The icon for this Tool.
keyin Accessor Inherited ReadOnly string AttachMapLayerByURLBaseTool Get the localized keyin string from this Tool's class
keyin Accessor Static Inherited ReadOnly string AttachMapLayerByURLBaseTool Get the localized keyin string for this Tool class. This returns the value of "tools." + this.toolId + ".keyin" from
its registered Namespace (e.g. "en/MyApp.json").
maxArgs Accessor Static Inherited ReadOnly number AttachMapLayerByURLBaseTool The maximum number of arguments allowed by AttachMapLayerByURLBaseTool.parseAndRun, or undefined if there is no maximum.
If subclasses override AttachMapLayerByURLBaseTool.parseAndRun, they should also override this method to indicate the maximum
number of arguments their implementation expects.
minArgs Accessor Static Inherited ReadOnly number AttachMapLayerByURLBaseTool The minimum number of arguments allowed by AttachMapLayerByURLBaseTool.parseAndRun. If subclasses override AttachMapLayerByURLBaseTool.parseAndRun, they should also
override this method to indicate the minimum number of arguments their implementation expects. UI controls can use
this information to ensure the tool has enough information to execute.
namespace Static Inherited string AttachMapLayerByURLBaseTool The namespace that provides localized strings for this Tool.
toolId Accessor Inherited ReadOnly string AttachMapLayerByURLBaseTool Get the toolId string for this Tool class. This string is used to identify the Tool in the ToolRegistry and is used to localize
the keyin, description, etc. from the current locale.

Defined in

Last Updated: 21 November, 2024