UnsharpenEffect Class

Adds a screen-space unsharpen effect to the selected Viewport.

Extends

Methods

Name Description
constructor(..._args: any[]): UnsharpenEffect    

Inherited methods

Name Inherited from Description
defineEffect(builder: ScreenSpaceEffectBuilder): void Protected Inherited ConvolutionEffect Add uniforms, varyings, etc.
parseAndRun(..._args: string[]): Promise<boolean> Inherited ConvolutionEffect Run this instance of a tool using a series of string arguments.
run(): Promise<boolean> Inherited ConvolutionEffect Run this instance of a Tool.
register(namespace?: string): void Static Inherited ConvolutionEffect Register this Tool class with the ToolRegistry.

Properties

Name Type Description
effectName Accessor Protected ReadOnly string Name of effect as used in keyins like fdt effect add.  
matrix Accessor Protected ReadOnly number[]    
toolId Static string The unique string that identifies this tool.  

Inherited properties

Name Type Inherited from Description
description Accessor Inherited ReadOnly string ConvolutionEffect Get the localized description string from this Tool's class
description Accessor Static Inherited ReadOnly string ConvolutionEffect Get the localized description for this Tool class. This returns the value of "tools." + this.toolId + ".description" from
its registered Namespace (e.g. "en/MyApp.json"). If that key is not in the localization namespace,
flyover is returned.
englishKeyin Accessor Static Inherited ReadOnly string ConvolutionEffect Get the English keyin string for this Tool class. This returns the value of "tools." + this.toolId + ".keyin" from
its registered Namespace (e.g. "en/MyApp.json").
flyover Accessor Inherited ReadOnly string ConvolutionEffect Get the localized flyover string from this Tool's class
flyover Accessor Static Inherited ReadOnly string ConvolutionEffect Get the localized flyover for this Tool class. This returns the value of "tools." + this.toolId + ".flyover" from
its registered Namespace (e.g. "en/MyApp.json"). If that key is not in the localization namespace,
keyin is returned.
hidden Static Inherited boolean ConvolutionEffect If true, this Tool will not appear in the list from ToolRegistry.getToolList.
iconSpec Accessor Inherited ReadOnly string ConvolutionEffect Get the iconSpec from this Tool's class.
iconSpec Static Inherited string ConvolutionEffect The icon for this Tool.
keyin Accessor Inherited ReadOnly string ConvolutionEffect Get the localized keyin string from this Tool's class
keyin Accessor Static Inherited ReadOnly string ConvolutionEffect Get the localized keyin string for this Tool class. This returns the value of "tools." + this.toolId + ".keyin" from
its registered Namespace (e.g. "en/MyApp.json").
maxArgs Accessor Static Inherited ReadOnly number ConvolutionEffect The maximum number of arguments allowed by parseAndRun, or undefined if there is no maximum.
If subclasses override parseAndRun, they should also override this method to indicate the maximum
number of arguments their implementation expects.
minArgs Accessor Static Inherited ReadOnly number ConvolutionEffect The minimum number of arguments allowed by parseAndRun. If subclasses override parseAndRun, they should also
override this method to indicate the minimum number of arguments their implementation expects. UI controls can use
this information to ensure the tool has enough information to execute.
namespace Static Inherited string ConvolutionEffect The namespace that provides localized strings for this Tool.
source Accessor Protected Inherited ReadOnly { fragment: string, vertex: string } ConvolutionEffect vertex, fragment, and optional sampleSourcePixel GLSL snippets.
textureCoordFromPosition Accessor Protected Inherited ReadOnly boolean ConvolutionEffect Whether the fragment shader should include built-in textureCoordFromPosition function.
toolId Accessor Inherited ReadOnly string ConvolutionEffect Get the toolId string for this Tool class. This string is used to identify the Tool in the ToolRegistry and is used to localize
the keyin, description, etc. from the current locale.

Defined in

Last Updated: 21 November, 2024