ConvolutionEffect Class
Adds one of a collection of "convolution kernels" that alter a Viewport's image by blending neighboring pixels. Based on https://webglfundamentals.org/webgl/lessons/webgl-image-processing-continued.html
Extends
Extended by
Methods
Name | Description | |
---|---|---|
constructor(..._args: any[]): ConvolutionEffect | ||
defineEffect(builder: ScreenSpaceEffectBuilder): void Protected | Add uniforms, varyings, etc. |
Inherited methods
Name | Inherited from | Description |
---|---|---|
parseAndRun(..._args: string[]): Promise<boolean> Inherited | AddEffectTool | Run this instance of a tool using a series of string arguments. |
run(): Promise<boolean> Inherited | AddEffectTool | Run this instance of a Tool. |
register(namespace?: string): void Static Inherited | AddEffectTool | Register this Tool class with the ToolRegistry. |
Properties
Name | Type | Description | |
---|---|---|---|
matrix Accessor Protected Abstract ReadOnly | number[] | ||
maxArgs Accessor Static ReadOnly | number | The maximum number of arguments allowed by parseAndRun, or undefined if there is no maximum. | |
minArgs Accessor Static ReadOnly | number | The minimum number of arguments allowed by parseAndRun. | |
source Accessor Protected ReadOnly | { fragment: string, vertex: string } | vertex, fragment, and optional sampleSourcePixel GLSL snippets. | |
textureCoordFromPosition Accessor Protected ReadOnly | boolean | Whether the fragment shader should include built-in textureCoordFromPosition function. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
description Accessor Inherited ReadOnly | string | AddEffectTool | Get the localized description string from this Tool's class |
description Accessor Static Inherited ReadOnly | string | AddEffectTool | Get the localized description for this Tool class. This returns the value of "tools." + this.toolId + ".description" from its registered Namespace (e.g. "en/MyApp.json"). If that key is not in the localization namespace, flyover is returned. |
effectName Accessor Protected Abstract Inherited ReadOnly | string | AddEffectTool | Name of effect as used in keyins like fdt effect add . Ideally one word. |
englishKeyin Accessor Static Inherited ReadOnly | string | AddEffectTool | Get the English keyin string for this Tool class. This returns the value of "tools." + this.toolId + ".keyin" from its registered Namespace (e.g. "en/MyApp.json"). |
flyover Accessor Inherited ReadOnly | string | AddEffectTool | Get the localized flyover string from this Tool's class |
flyover Accessor Static Inherited ReadOnly | string | AddEffectTool | Get the localized flyover for this Tool class. This returns the value of "tools." + this.toolId + ".flyover" from its registered Namespace (e.g. "en/MyApp.json"). If that key is not in the localization namespace, keyin is returned. |
hidden Static Inherited | boolean | AddEffectTool | If true, this Tool will not appear in the list from ToolRegistry.getToolList. |
iconSpec Accessor Inherited ReadOnly | string | AddEffectTool | Get the iconSpec from this Tool's class. |
iconSpec Static Inherited | string | AddEffectTool | The icon for this Tool. |
keyin Accessor Inherited ReadOnly | string | AddEffectTool | Get the localized keyin string from this Tool's class |
keyin Accessor Static Inherited ReadOnly | string | AddEffectTool | Get the localized keyin string for this Tool class. This returns the value of "tools." + this.toolId + ".keyin" from its registered Namespace (e.g. "en/MyApp.json"). |
namespace Static Inherited | string | AddEffectTool | The namespace that provides localized strings for this Tool. |
toolId Accessor Inherited ReadOnly | string | AddEffectTool | Get the toolId string for this Tool class. This string is used to identify the Tool in the ToolRegistry and is used to localize the keyin, description, etc. from the current locale. |
toolId Static Inherited | string | AddEffectTool | The unique string that identifies this tool. |
Defined in
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.