assertIsRelationshipClass MethodStatic
Type assertion to check if the SchemaItem is of type RelationshipClass.
assertIsRelationshipClass(item?: SchemaItem): item is RelationshipClass
@returns The item cast to RelationshipClass if it is a RelationshipClass, undefined otherwise.
Parameter | Type | Description |
---|---|---|
item | SchemaItem | The SchemaItem to check. |
Returns - item is RelationshipClass
The item cast to RelationshipClass if it is a RelationshipClass, undefined otherwise.
Defined in
Last Updated: 21 February, 2025
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.