SchemaValidater Class
Applies EC Rules, see ECRuleSet, to a given Schema and reports any violations.
Methods
Name | Description | |
---|---|---|
constructor(): SchemaValidater | ||
validateSchema(schema: Schema, validaterRuleSet?: IRuleSet): Promise<AnyDiagnostic[]> Static | Validates a schema against the ECRuleSet. |
Defined in
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.