GlobalContextMenuProps Interface
Deprecated in 4.16.0. Props of deprecated GlobalContextMenu component.
Properties for the GlobalContextMenu component
Extends
Properties
Name | Type | Description | |
---|---|---|---|
contextMenuComponent | React.ComponentType<ContextMenuProps> | undefined | Context menu element. | |
identifier | string | undefined | Unique identifier, to distinguish from other GlobalContextMenu components. | |
x | string | number | Specifies the x/horizontal position on the viewport. | |
y | string | number | Specifies the y/vertical position on the viewport. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
autoflip | boolean | undefined | ContextMenuProps | Whether menu flips directions based on screen edge. |
children | React.ReactNode | undefined | ContextMenuProps | Content |
className | string | undefined | ContextMenuProps | Custom CSS class name |
direction | ContextMenuDirection | undefined | ContextMenuProps | Which direction the menu opens. |
edgeLimit | boolean | undefined | ContextMenuProps | Whether menu hugs screen edge when autoflip is off. |
floating | boolean | undefined | ContextMenuProps | whether menu floats on the viewport, or the page. |
hotkeySelect | boolean | undefined | ContextMenuProps | Whether Hotkey press selects item, or just highlights item. |
itemId | string | undefined | ContextMenuProps | Optional unique identifier for item. |
onEsc | (data: any) => any | undefined | ContextMenuProps | when Escape button is pressed |
onOutsideClick | (event: MouseEvent) => any | undefined | ContextMenuProps | When click is registered outside of ContextMenu. |
onSelect | (event: any) => any | undefined | ContextMenuProps | When list item or submenu is selected |
opened | boolean | ContextMenuProps | Whether ContextMenu is currently opened. |
selectedIndex | number | undefined | ContextMenuProps | starting menu item selected index Default: -1 |
style | React.CSSProperties | undefined | ContextMenuProps | Custom CSS style properties |
Defined in
Last Updated: 20 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.