createMiteredSweepSections MethodStatic
Sweep the initialSection
along each segment of the (stroked) centerline
until it hits the bisector plane at
the next vertex.
- For best results, the caller should place
initialSection
in a plane perpendicular to thecenterline
start tangent.- This plane is commonly (but not necessarily) through the centerline start point itself.
- To compute the sections,
initialSection
is projected in the direction of the centerline start tangent onto the first bisector plane at the centerline start. The result of this projection will be likewise projected onto the second plane, and so on in sequence.
- By default, the first/last bisector plane normals are set to the centerline start/end tangents. The caller can
override these with tangents supplied in
options
. If the centerline is physically closed andoptions.wrapIfPhysicallyClosed
is true, the first and last plane normals are averaged and equated. - The centerline path does NOT have to be planar, however non-planarity will result in twisting of the sections in the bisector planes.
createMiteredSweepSections(centerline: IndexedXYZCollection | Point3d[] | CurvePrimitive | CurveChain, initialSection: AnyCurve, options?: MiteredSweepOptions): undefined | SectionSequenceWithPlanes
@returns array of sections, formed from projecting initialSection
successively onto the bisector planes.
Parameter | Type | Description |
---|---|---|
centerline | IndexedXYZCollection | Point3d[] | CurvePrimitive | CurveChain | sweep path. Will be stroked if smooth. |
initialSection | AnyCurve | profile curve to be swept. As noted above, this should be on a plane perpendicular to the centerline start tangent. |
options | MiteredSweepOptions | options for computation and output. |
Returns - undefined | SectionSequenceWithPlanes
array of sections, formed from projecting initialSection
successively onto the bisector planes.
Defined in
- curve/CurveFactory.ts Line 551
Last Updated: 18 January, 2025
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.