MiteredSweepOptions Interface
Interface bundling options for [CurveFactory.createMiteredSweepSections].
Properties
Name | Type | Description | |
---|---|---|---|
capped | boolean | undefined | Whether to cap the ruled sweep if outputting a ruled sweep or mesh. | |
endTangent | Vector3d | undefined | The last section's normal is aligned to this vector, typically the end tangent of the smooth curve stroked for the centerline. | |
outputSelect | MiteredSweepOutputSelect | undefined | Whether to output sections only, or sections plus optional geometry constructed from them. | |
startTangent | Vector3d | undefined | The first section's normal is aligned to this vector, typically the start tangent of the smooth curve stroked for the centerline. | |
strokeOptions | StrokeOptions | undefined | How to stroke smooth input curves. | |
wrapIfPhysicallyClosed | boolean | undefined | Whether first and last planes are averaged and equated when the centerline is physically closed. |
Defined in
- curve/CurveFactory.ts Line 83
Last Updated: 18 January, 2025
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.