SectionSequenceWithPlanes Interface

Interface to carry parallel arrays of planes and sections, and optional geometry assembled from them, as returned by [CurveFactory.createMiteredSweepSections].

Properties

Name Type Description
mesh IndexedPolyface | undefined Optional mesh generated from the RuledSweep generated from the sections.  
planes Plane3dByOriginAndUnitNormal[] The plane of each section.  
ruledSweep RuledSweep | undefined Optional RuledSweep generated from the sections.  
sections AnyCurve[] Section curve projected onto the corresponding plane.  

Defined in

Last Updated: 18 January, 2025