createRigidFromMatrix3d MethodStatic
Create a new orthogonal matrix by calling makeRigid on a clone of source
.
createRigidFromMatrix3d(source: Matrix3d, axisOrder: AxisOrderAxisOrder.XYZ, result?: Matrix3d): undefined | Matrix3d
@returns rigid matrix, or undefined
if the operation failed.
Parameter | Type | Description |
---|---|---|
source | Matrix3d | input matrix |
axisOrder | AxisOrder | how to reorder the matrix columns. A left-handed ordering will return a mirror. |
result | Matrix3d | optional preallocated result to populate and return |
Returns - undefined | Matrix3d
rigid matrix, or undefined
if the operation failed.
Defined in
- geometry3d/Matrix3d.ts Line 2861
Last Updated: 26 April, 2025
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.