AxisOrder Enumeration

Enumeration of the 6 possible orderings of XYZ axis order

  • AxisOrder encodes handedness as well. There are 3 right-handed axis orderings (XYZ, YZX, ZXY) and 3 left-handed orderings (XZY, YXZ, ZYX).
  • Given an axis ordering, the cross product of axis i with axis i+1 yields axis i+2.

Members

Name Value Description
XYZ Right handed system, X then Y then Z
XZY Left handed system, X then Z then Y
YXZ Left handed system, Y then X then Z
YZX Right handed system, Y then Z then X
ZXY Right handed system, Z then X then Y
ZYX Left handed system, Z then Y then X

Defined in

Last Updated: 03 April, 2025