makeRigid Method
Adjust the matrix in place to make it rigid:
- Columns are perpendicular and have unit length.
- Transpose equals inverse.
makeRigid(axisOrder: AxisOrderAxisOrder.XYZ): boolean
@returns whether the adjusted matrix is rigid on return
Parameter | Type | Description |
---|---|---|
axisOrder | AxisOrder | how to reorder the matrix columns. A left-handed ordering will return a mirror. |
Returns - boolean
whether the adjusted matrix is rigid on return
Defined in
- geometry3d/Matrix3d.ts Line 2845
Last Updated: 26 April, 2025
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.