BSplineCurveOps.C2CubicFit Class

A helper class for creating C2 cubic fit curves. Knots herein are understood to be interior knots (including the start/end knot), so that there is one knot per fit point. In other words, the knots are fit parameters.

Methods

Name Description
constructor(): BSplineCurveOps.C2CubicFit    
constructFitParameters(options: InterpolationCurve3dOptions): boolean Static Construct fit parameters for the c2 cubic fit algorithm, if they are missing.  
constructFitParametersFromPoints(fitPoints: Point3d[], isChordLength: number, closed: boolean): undefined | number[] Static Construct fit parameters for the c2 cubic fit algorithm.  
constructPoles(options: InterpolationCurve3dOptions): undefined | Float64Array | Point3d[] Static Construct the control points for the c2 cubic fit algorithm  
convertCubicKnotVectorToFitParams(knots: number[], numFitPoints: number, normalize?: boolean): undefined | number[] Static Converts a full cubic knot vector of expected length into fit parameters, by removing extraneous exterior knots.  
convertFitParamsToCubicKnotVector(params: number[], closed?: boolean, legacy?: boolean): undefined | number[] Static Return fit parameters augmented to a full cubic knot vector.  
convertToJsonKnots(props: InterpolationCurve3dProps): void Static Ensure full legacy knot vector for JSON export *  
validateOptions(options: InterpolationCurve3dOptions): boolean Static Adjust options by correcting invalid combinations  

Defined in

Last Updated: 26 April, 2025