createCompressed MethodStatic
Clone the input array with each successive duplicate point removed.
- First and last points are always preserved.
createCompressed(source: IndexedXYZCollection, tolerance: numberGeometry.smallMetricDistance, result?: GrowableXYZArray): GrowableXYZArray
@see cloneCompressed, compressInPlace, compressShortEdges
Parameter | Type | Description |
---|---|---|
source | IndexedXYZCollection | the source array |
tolerance | number | optional distance tol for compression (default smallMetricDistance) |
result | GrowableXYZArray | optional pre-allocated object to populate and return. Can be a reference to source , inwhich case the array is compressed in place and returned. |
Returns - GrowableXYZArray
Defined in
- geometry3d/GrowableXYZArray.ts Line 151
Last Updated: 18 January, 2025
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.