compressInPlace Method
Compress the input array by removing successive duplicate points.
- First and last points are always preserved.
compressInPlace(tolerance: numberGeometry.smallMetricDistance): GrowableXYZArray
@returns the instance array.
@see createCompressed, cloneCompressed, compressShortEdges
Parameter | Type | Description |
---|---|---|
tolerance | number | optional distance tol for compression (default smallMetricDistance) |
Returns - GrowableXYZArray
the instance array.
Defined in
- geometry3d/GrowableXYZArray.ts Line 187
Last Updated: 18 January, 2025
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.