cloneCompressed Method

Clone the instance array with each successive duplicate point removed.

  • First and last points are always preserved.

cloneCompressed(tolerance: numberGeometry.smallMetricDistance, result?: GrowableXYZArray): GrowableXYZArray

@see createCompressed, compressInPlace, compressShortEdges

Parameter Type Description
tolerance number optional distance tol for compression (default smallMetricDistance)
result GrowableXYZArray optional pre-allocated object to populate and return. Can be a reference to the instance array, in
which case the array is compressed in place and returned.

Returns - GrowableXYZArray

Defined in

Last Updated: 18 January, 2025