AccuDrawShortcuts Class
A shortcut may require no user input (immediate) or it may install a tool to collect the needed input. AccuDrawShortcuts are how users control AccuDraw. A tool implementor should not use this class to setup AccuDraw, instead use AccuDrawHintBuilder to provide hints.
Methods
Name | Description | |
---|---|---|
constructor(): AccuDrawShortcuts | ||
alignView(): void Static | ||
changeCompassMode(): void Static | ||
chooseNextValue(index: ItemField): void Static | ||
choosePreviousValue(index: ItemField): void Static | ||
clearSavedValues(): void Static | ||
defineACSByElement(): Promise<boolean> Static | ||
defineACSByPoints(): Promise<boolean> Static | ||
getACS(acsName: string, useOrigin: boolean, useRotation: boolean): BentleyStatus Static | ||
itemFieldAcceptInput(index: ItemField, str: string): Promise<void> Static | ||
itemFieldCompletedInput(index: ItemField): void Static | ||
itemFieldLockToggle(index: ItemField): void Static | ||
itemFieldNavigate(index: ItemField, str: string, forward: boolean): Promise<void> Static | ||
itemFieldNewInput(index: ItemField): void Static | ||
itemFieldUnlockAll(): void Static | ||
itemRotationModeChange(rotation: RotationMode): void Static | ||
lockAngle(): void Static | ||
lockDistance(): void Static | ||
lockIndex(): void Static | Disable indexing when not currently indexed; if indexed, enable respective lock. | |
lockSmart(): void Static | ||
lockX(): void Static | ||
lockY(): void Static | ||
lockZ(): void Static | ||
processPendingHints(): void Static | ||
requestInputFocus(): void Static | ||
rotate90(axis: number): void Static | ||
rotateAxes(aboutCurrentZ: boolean): Promise<boolean> Static | ||
rotateAxesByPoint(isSnapped: boolean, aboutCurrentZ: boolean): boolean Static | ||
rotateCycle(): void Static | ||
rotatePerpendicular(): Promise<boolean> Static | ||
rotateToACS(): void Static | ||
rotateToBase(): void Static | ||
rotateToElement(): Promise<boolean> Static | ||
sessionToggle(): void Static | Disable/Enable AccuDraw for the session | |
setOrigin(explicitOrigin?: Point3d): void Static | ||
setStandardRotation(rotation: RotationMode): void Static | ||
suspendToggle(): void Static | Suspend/Unsuspend AccuDraw for the active tool | |
updateACSByPoints(acs: AuxCoordSystemState, vp: Viewport, points: Point3d[], isDynamics: boolean): boolean Static | ||
writeACS(_acsName: string): BentleyStatus Static |
Defined in
Last Updated: 05 February, 2025
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.