TileRequestChannels Class
A set of named TileRequestChannels via which content for Tiles can be requested.
@see - channels for the channels configured for use with the iTwin.js display system.
- getForHttp for the most typical way of obtaining or registering a channel.
Methods
Name | Description | |
---|---|---|
[iterator](): Iterator<TileRequestChannel, any, any> | Iterator over all of the channels. | |
add(channel: TileRequestChannel): void | Add a new channel. | |
get(name: string): undefined | TileRequestChannel | Look up a registered channel by its name. | |
getForHttp(name: string): TileRequestChannel | Obtain a channel that requests content over HTTP using HTTP 1.1 limits on simultaneous connections. | |
has(channel: TileRequestChannel): boolean | Return whether the specified channel has been registered. | |
resetStatistics(): void | Reset all statistics to zero. | |
getNameFromUrl(url: string | URL): string Static | Extract the host name from a URL for use as the name of the corresponding TileRequestChannel. |
Properties
Name | Type | Description | |
---|---|---|---|
elementGraphicsRpc Readonly | TileRequestChannel | The channel over which requestElementGraphics executes. | |
httpConcurrency Readonly | "6" | The maximum number of active requests for a channel that uses HTTP to request content. | |
rpcConcurrency Accessor ReadOnly | number | The maximum number of active requests for a channel that uses an RpcInterface to satisfy its requests. | |
size Accessor ReadOnly | number | The number of registered channels. | |
statistics Accessor ReadOnly | TileRequestChannelStatistics | Statistics intended primarily for debugging. |
Defined in
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.