EllipsoidTerrainProvider Class
A terrain mesh provider that produces geometry that represents a smooth ellipsoid without any height perturbations. The area within the project extents are represented as planar tiles and other tiles are facetted approximations of the WGS84 ellipsoid. This is the terrain provider used when the background map is enabled but 3d terrain is disabled.
Extends
Methods
Name | Description | |
---|---|---|
constructor(opts: TerrainMeshProviderOptions): EllipsoidTerrainProvider | Construct a new terrain provider. | |
getChildHeightRange(_quadId: QuadId, _rectangle: MapCartoRectangle, _parent: MapTile): undefined | Range1d | Implements getChildHeightRange to return an empty range, because the ellipsoid is smooth. | |
requestMeshData(): Promise<TileRequest.Response> | Implements requestMeshData to return an empty string because the mesh can be generated |
Inherited methods
Name | Inherited from | Description |
---|---|---|
addLogoCards(_cards: HTMLTableElement, _vp: ScreenViewport): void Inherited | TerrainMeshProvider | Add attribution logo cards for the terrain data supplied by this provider to the Viewport's logo div. |
forceTileLoad(_tile: MapTile): boolean Inherited | TerrainMeshProvider | Returns true if the specified tile should always be loaded. |
isTileAvailable(_quadId: QuadId): boolean Inherited | TerrainMeshProvider | Return whether terrain data can be obtained for the MapTile specified by quadId . |
Properties
Name | Type | Description | |
---|---|---|---|
maxDepth Accessor ReadOnly | number | Implements maxDepth to return a fixed maximum depth of 22. | |
tilingScheme Accessor ReadOnly | MapTilingScheme | Implements tilingScheme. |
Defined in
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.