ParticleCollectionBuilderParams Interface
Parameters used to construct a ParticleCollectionBuilder.
Properties
Name | Type | Description | |
---|---|---|---|
isViewCoords | boolean | undefined | If true, the finished graphic will be defined in view coordinates, for use as a decoration of type ViewBackground or ViewOverlay. | |
origin | Readonly<WritableXYAndZ> | undefined | The origin of the particle collection in world coordinates. | |
pickableId | string | undefined | If the particles are to be pickable, a unique identifier to associate with the resultant RenderGraphic. | |
size | number | Readonly<WritableXAndY> | The default extents of the particle quad. | |
texture | RenderTexture | The image mapped to each particle quad. | |
transparency | number | undefined | The initial transparency of the particles as an integer in [0,255]. | |
viewport | Viewport | The viewport in which the particles will be drawn. |
Defined in
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.