createGraphicBuilder Method
Create a builder for creating a RenderGraphic of the specified type appropriate for rendering within this context's Viewport.
createGraphicBuilder(type: GraphicType, transform?: Transform, id?: string): GraphicBuilder
@returns A builder for creating a RenderGraphic of the specified type appropriate for rendering within this context's Viewport.
@see - transientIds for obtaining an ID for a pickable decoration.
- createGraphic for more options.
Parameter | Type | Description |
---|---|---|
type | GraphicType | The type of builder to create. |
transform | Transform | the local-to-world transform in which the builder's geometry is to be defined. |
id | string | If the decoration is to be pickable, a unique identifier to associate with the resultant RenderGraphic. |
Returns - GraphicBuilder
A builder for creating a RenderGraphic of the specified type appropriate for rendering within this context's Viewport.
Defined in
- core/frontend/src/ViewContext.ts Line 186
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.